Prosperative Public Forum

Problem and unable to access the appropriate forum

0 Members and 1 Guest are viewing this topic.

Offline julescu

  • *
  • 4
    • View Profile
    • Email
  • Skype: JulieCurry.NSW
Problem and unable to access the appropriate forum
« on: April 12, 2018, 09:29:19 PM »
This problem is to do with Article Builder.  Unfortunately I cannot access the forum regarding that product, so will enter my problem/question here.  Meg, I'm hoping you can help me out again! :)
Has anyone found a work around for connecting to https sites that have acquired their secure status via a 301 redirect from CloudFlare?
Despite over four hours on live chat with the techies at Hostgator, the issue is unresolved & I continue to get the following error messages in Article Builder:

Your form submission contained the following errors:

Failed to connect to the blog: 5 => Didn't receive 200 OK from remote server. (HTTP/1.1 301 Moved Permanently)
So we can post successfully to your blog, your hosting has to accept something called XML-RPC connections. It may also need to have our IP 107.173.57.119 "whitelisted". Our system uses XML-RPC connections to your blog in order to be able to post articles and images for you. Please contact your web host and give these error messages to them.

If anyone has come across this problem & found a work around I'd be very grateful to hear it.  Thanks

Offline Meg

  • *****
  • 7490
  • Freedup to do what you really want
    • View Profile
Re: Problem and unable to access the appropriate forum
« Reply #1 on: April 13, 2018, 12:34:09 AM »
You need to contact helpdesk. The XML - RPC connection problem has happened to other people previously but I don't know what had to be done to rectify it. http://support.prosperative.com/

Re: Problem and unable to access the appropriate forum
« Reply #2 on: April 13, 2018, 01:24:34 AM »
Hi Julie

If I remember correctly when using cloud flare you change the DNS of your site to cloudflare's server and and give them your "real IP", so any access is first going to cloud flare and only then cloud flare fetches new content from your site.
One way to work around this might be to make your site accessible under a subdomain that is not redirected to cloudflare, so that Article builder will actually access your site and not cloudflare's server when trying to upload content.

Mike